Degraded performance

Incident Report for BusyBees

Resolved

This incident has been resolved.
Posted Aug 03, 2026 - 13:52 BST

Investigating

We are observing degraded performance and are looking into the cause.
Posted Aug 03, 2026 - 13:35 BST
This incident affected: Busy Bees App and app.busybees.com.